Error: Check Your IP Access Settings and Add the IPs to the IP Allow List
Issue
Syncs fail. The following error appears:
Couldn't connect to your SFTP server - Check your IP access settings and add the IPs to the IP allow list.
Environment
Connector: SFTP
Resolution
To resolve this issue, do the following:
Safelist the applicable Fivetran IP addresses for your provider, region, and location on your SFTP server. For more information, see our IP Addresses documentation.
Ensure the SSH key or credentials you provided while setting up your connection are correct and match those configured on the SFTP server. To check your connection's configuration, do the following:
i. In Fivetran, go to your SFTP connection page.
ii. Select the Setup tab.
iii. Click Edit connection.
iv. Review all fields and make any necessary changes.
v. If you have made any changes, click Save & Test.
If the issue occurs intermittently, monitor the connection's performance to identify patterns or triggers that coincide with the errors.
Cause
This issue may occur when we can't connect to the SFTP server due to missing IP safelist entries or authentication issues. In some cases, transient network issues or firewall restrictions may also disrupt the connection.