Error: Log File for Oldest Open Transaction Is Not Available
Issue
The following error appears:
The log file for the oldest open transaction (null, started at 0) is not available.
Environment
Connector: Oracle RAC
Resolution
To resolve this issue, complete one of the following steps:
- Restore the missing archive logs so Fivetran can access them.
- Commit or roll back the long-running transaction. This action may be disruptive and may not be possible for Oracle E-Business Suite (EBS).
- If the archive logs no longer exist and you can't close the transaction, contact Fivetran support to ignore the transaction and resume from a more recent SCN.
For more information, see Capture Start and Long-Running Transactions.
Cause
This issue occurs when a transaction remains open long enough for the archive logs containing the transaction's start SCN to expire and be purged. When this happens, we attempt to start change capture from the SCN of the oldest open uncommitted transaction, but can't do so when the required redo or archive log is no longer available.