Error - F_JD5E07 Oracle Charset ID '153' for Oracle ASM
Issue
While connecting to an Oracle ASM instance, the following error appears:
F_JD5E07: Oracle charset ID '153' for Oracle SID '+ASM1' with user 'dsstream_asm' is not supported.
As a result, the connection can't connect to the Oracle ASM instance, and ASM archive log access fails.
Environment
- Connector: HVA for Oracle
- Oracle environment: Oracle ASM
Resolution
To resolve this issue, do the following:
On the host where the HVA agent is running, check the Oracle-related environment variables:
env | egrep 'NLS_LANG|NLS_NCHAR|ORACLE_HOME|TNS_ADMIN'Verify that the following variables are set correctly for the Oracle environment used by the HVA agent:
NLS_LANGNLS_NCHARORACLE_HOMETNS_ADMIN
If the host has multiple Oracle homes, verify that the HVA agent is using the correct Grid Infrastructure or ASM Oracle home for ASM access.
Compare the database and ASM character set settings:
i. On the Oracle database instance, run:
SELECT * FROM nls_database_parameters;ii. On the Oracle ASM instance, run:
SELECT * FROM v$nls_parameters;iii. Check the
NLS_CHARACTERSETvalues. Oracle databases commonly useAL32UTF8. If the ASM instance is using an unsupported character set, work with your Oracle DBA to update the ASM connection configuration or character set settings as appropriate.If the issue persists, configure ASM connectivity using the ASM TNS option in the connection setup form. This forces the connection to use the specified ASM connection configuration instead of automatic ASM discovery. For more information, see the HVA for Oracle setup guide.
Cause
This issue occurs when we detect an unsupported character set while connecting to the Oracle ASM instance. Oracle charset ID 153 corresponds to AL16UTF16, which is not supported for ASM connections.