Error: Revalidate TLS Certificate
Issue
Fivetran displays the following error:
Revalidate TLS Certificate
Environment
All database connectors
Answer
To resolve this issue, revalidate the TLS certificate for your connection:
- In Fivetran, go to the relevant connection page.
- Select the Setup tab.
- Click Test Connection.
- When the TLS certificate prompt appears, review and accept the certificate.
If the prompt does not appear or the issue persists, force Fivetran to request the certificate again:
- Go to Account Settings > General.
- Scroll down to Validated Certificates & Keys and locate the certificate for the affected connection. For more information about this section, see Validated Certificates & Keys.
- Click the revoke icon in the row and confirm the revocation.
- Return to the connection and repeat the steps above to revalidate the new certificate.
Cause
TLS certificate revalidation errors are caused by the following:
- Database reboots that reset the certificate
- An expired certificate
- A modified certificate
More information
TLS certificates have an expiration date or are renewed by your database service. When you do not issue the certificates and your database service manages them, these are usually self-signed certificates.
Self-signed certificates do not have a well-known Certification Authority (CA), and for security reasons, we need you to trust these for your account. Once the certificate is trusted, we will remember it as long as it is not expired.