Error: Unable To Find Matching Files
Issue
Setup tests fail or the connector is not loading all files from the subdirectories in your bucket. The following error appears:
Unable to find matching files.
Environment
Connector: Amazon S3
Resolution
To resolve this issue, do the following:
- In your Fivetran dashboard, go to your Amazon S3 connector page.
- Select the Setup tab.
- Click Edit connection details.
- Check that the Bucket you have provided contains the applicable files.
- If you have provided a Folder Path, ensure it is correct and directs to the applicable folder.
- If you have provided a regular expression (regex) File Pattern or Archive Folder Pattern, ensure it can detect the applicable files or folders. You can use Rubular to test your regex.
Cause
This issue occurs if we're unable to find any files or the file pattern or archive folder pattern you provided are invalid.