Error: The Level of Configured Provisioned Throughput for the Table Was Exceeded
Issue
The connector fails with the following error:
ProvisionedThroughputExceededException: The level of configured provisioned throughput for the table was exceeded. Consider increasing your provisioning level with the UpdateTable API.
Environment
Connector: Amazon DynamoDB
Resolution
To resolve this issue, increase the read/write capacity of the affected tables. There are two ways you can achieve this:
On-demand mode
Set the affected tables' read/write capacity mode to on-demand. The on-demand read/write capacity mode dynamically provides the required read capacity unit (RCU).
Provisioned mode
Set the affected tables' read/write capacity mode to provisioned and manually set the RCU value.
You need 1 RCU for every 8 Kbps of extract speed. For example, a 30 Mbps (30720 Kbps) extract speed requires 3840 RCU. Go to your Sync History chart and calculate an approximate extract speed using the sync extract time and data volume.
You don't need to trigger a re-sync once you have set each table's read/write capacity mode to on-demand or provisioned. If you need to trigger re-syncs in the future, we recommend setting each table's read/write capacity mode to on-demand and reverting as required when the re-sync is complete.
Cause
To optimize the connector's sync speed, we divide each table into 16 segments and utilize 16 threads to scan each segment in parallel. This issue may occur during re-imports if using 16 threads to scan a table results in exceeding the read-throughput capacity you have provisioned.