Error: Unable To Connect to API
Issue
Setup tests fail. The following error appears:
Unable to connect to API. Failed to connect to API.
Environment
Connector: SharePoint
Resolution
To resolve the error, do the following:
- In the Folder Path field of the setup form, ensure you have provided the complete SharePoint URL for your folder rather than the folder path.
- Ensure you have correctly provided Fivetran access to your SharePoint site. See step 2 of our SharePoint setup guide for more information.
Cause
This issue occurs when you provide an incorrect or incorrectly formatted value in the setup form's Folder Path field or you don't authorize and approve the Fivetran application correctly in SharePoint.