Error: Unable to Validate Certificate: Undefined Error
Issue
A connection configured to directly connect to an Oracle database fails. The following error appears:
Unable to validate certificate. dbCertificateValidation2: java.sql.SQLRecoverableException: 10 Error: Undefined Error
Environment
- Connector: Oracle
- Connection method: Direct
Resolution
To resolve this issue, do the following:
- Verify that TLS is enabled on your Oracle database by checking the SSL/TLS configuration files and connection settings. For more information, see Oracle's setup and configuration instructions with a client wallet or without a client wallet.
- Check that TLS certificates are installed and correctly configured. For more information on managing certificates, see Oracle's Create a Certificate for TLS Connection documentation.
- Make sure the Oracle database host and port allow inbound TLS connections from Fivetran's IP addresses, considering firewall or access control settings specific to your hosting environment (cloud, on-premises, etc.).
Your database's port is usually
1521
for unencrypted connections and2484
for encrypted connections using SSL/TLS. - Verify that you have created and configured a read-only user for Fivetran by following steps 2–3 in our Oracle setup guide.
Cause
This issue may occur for any of the following reasons:
- TLS is not enabled on the database.
- TLS certificates are missing, misconfigured, expired, or revoked.
- The database is not configured to accept TLS connections.