A Table or Column Is Missing From the Destination
Issue
A table or column that is available in the source is missing from the destination.
Environment
Application or database connectors
Resolution
To troubleshoot this issue, do the following:
- In Fivetran, go to the Schema tab of the connection page and confirm that the table or column is enabled for sync.
- For API-based connectors, review the ERD in the Schema information section of the connector documentation to find out where the table or column should appear and whether it's supported. Table names in the ERD may differ from those in the source application. To find out why a table or column isn't supported, contact our support team.
- Check that the table or column contains data in the source.
NOTE: For most connectors, Fivetran doesn't create empty tables and columns in your destination. For the list of connectors that support empty tables, see our Syncing empty tables documentation.
- If the missing field is a custom field, confirm that the connector supports syncing custom data. For more information, see the Features section of the connector documentation.
- Check the source for any permissions set that may prevent the authorizing user from accessing applicable tables or columns.
Cause
A source table or column may not be available in the destination due to one of the following reasons:
- The table or column is not enabled for sync.
- There is no data in the source, and Fivetran doesn't sync empty tables for the connector.
- The table or column is not supported.
- The column may be synced to a different table than expected.
- Source permissions prevent us from accessing the field.