A Field or Table From the Source Is Missing in the Destination
Issue
A field or table that is available in the source is missing in the destination.
Environment
Application or database connectors
Resolution
To understand the cause of this issue, do the following:
- In the Fivetran dashboard, visit the Schema tab of the connector to verify that the table or field is enabled for sync.
- For API-based connectors, check the connector ERD to verify the table it may be in. The ERD is found in the Schema Information section of the connector documentation. The table name may differ from the name found in the source application.
- Check that the field contains data in the source.
- If the field is a custom field, check that the connector supports syncing custom data. You can find this information in the Features section of the connector documentation.
- Check that the connector ERD or documentation gives reference to the applicable field. If not, then it may not be synced. Reach out to the Support Team for help identifying the reason it is not available.
- Check the source for any permissions set that may prevent access the Fivetran-connected user from accessing applicable fields or tables.
If you have followed the steps above and the cause is still not clear, contact the Support Team.
Cause
A source field or table may not be available in the destination due to one of the following causes:
- The table or field is not enabled for sync.
- There is no data in the source. In most cases, Fivetran does not sync empty tables or fields.
- The field is not supported for sync.
- The field may be synced to a different table than expected.
- Permissions in the source may prevent the connector from accessing the field.