Long Process or Load Time
Issue
My sync process or load times are taking longer than expected, as shown in my connector's Sync History chart.
Environment
All connectors
Resolution
We recommend monitoring the destination server's CPU, memory, and disk space for any hardware issues that may impact your sync time.
If multiple connectors sync data to your destination at the same time, you can reduce the maximum load on your destination server by adjusting each connector's sync frequency. See our sync frequency documentation for more information. To adjust an existing connector's sync frequency, do the following:
- In your Fivetran dashboard, go to your connector page.
- Select the Setup tab.
- Update the value in the Sync Frequency drop-down menu.
If your destination server's resources are reaching their maximum allotment during syncs, you can optimize the process and load times by increasing the number of resources allocated to your destination server.
Cause
We run each sync's process and load steps on your destination host. This issue occurs when the load on your destination server or its performance affect our ability to process your sync efficiently.