Unable to Update a Connector SDK Package
Issue
When calling:
PATCH /v1/connector-sdk/packages/{package_id}
you may receive the following error:
Forbidden: Only the package owner or an account administrator can update the package.
This applies to Connector SDK package updates performed directly through the REST API. This error can occur regardless of whether you are using a Scoped API key or a System API key.
Environment
Fivetran Connector SDK
Resolution
If you can’t update the existing package:
- Create a new package using the API key that should manage the package going forward.
- Update your existing connection to reference the new
package_id.{ "config": { "package_id": "new_package_id" } } - Run the next sync.
If a sync is already running, it completes using the previous package. The next sync uses the new package.
Cause
Connector SDK packages can only be updated by:
- The API key used to created the package
- An Account Administrator.
Otherwise, the request fails.